pbReview.com - Paintball Reviews and Paintball Fields

  Join pbReview.com  |  Log In  
pbReview.com - Paintball Reviews and Paintball Fields

Search:

  
Home     |     Paintball Articles     |     Paintball Videos     |     Paintball Gear     |     Paintball Fields     |     Paintball Stores     |     Hot Deals     |     Paintball Forums     |     Chat
Go Back   Paintball Forums > Specific Marker Forums > JT USA


Reply
 
Thread Tools Display Modes
Old 01-27-2011, 11:14 PM   #1
Hekter
Registered User
 
Join Date: Jan 2011
Talking JT Excellarator 3.5.

Hi guys,
I took apart 2 markers JT Excellator 3.5., installed new o-rings, except for possibly an o-ring on the striker. I took one gun to a paintball to test it with HPA and noticed it spuddered and would not re-cock. I'm new at this hobby however hot shot markers. My guess is that the marker needs a new o-ring on the striker and maybe some polishing and oil based a thread by used condom(former name of member). PB store wants $25.00 to diagnose/fix problem. I have two of these markers and need to know where I can buy inexpensive HPA tanks.

Hekter
Hekter is offline   Reply With Quote
Old 02-01-2011, 03:16 PM   #2
Hekter
Registered User
 
Join Date: Jan 2011
Unhappy JT Excellator 3.5 update

Humm,
Not even a response from a mod! Anyhow I oiled and took both markers apart and noticed one of them leaked bad during testing! The other marker still lspudders even after changing the o-ring on the striker,oiling all o-rings and testing the marker with a tank of CO2. Gun still spuddered. PB shop told me I was using the wrong o-rings which I purchased from a reputable shop. I tried adjusting the velocity screw to no avail on the marker that spudders. I actually unscrewed the whole screw to see if air would leak from the velocity screw area and had no leak? Go figure. Let me know your thoughts Mod's and others. Are these markers doorstops or are they worth fixing.

Thanks, Hekter
Hekter is offline   Reply With Quote
Old 02-01-2011, 04:23 PM   #3
Ironman289
Paintball......
 
Ironman289's Avatar
 
Join Date: Apr 2009
Location: minnesota
They work fine. I will look at mine (haven't used it in a year) and then try and figure out what is going on with yours. Sounds like the sear could be worn and not catching on the hammer.
Ironman289 is offline   Reply With Quote
Reply



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 11:03 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Help / FAQ  |  Contact Us  |  About Us  |  Advertising Info  |  Link to Us  |  Privacy Policy  |  Terms of Use
Top

Paintball Review

Copyright © 2000-2007 Hillclimb Media