pbReview.com - Paintball Reviews and Paintball Fields

  Join pbReview.com  |  Log In  
pbReview.com - Paintball Reviews and Paintball Fields

Search:

  
Home     |     Paintball Articles     |     Paintball Videos     |     Paintball Gear     |     Paintball Fields     |     Paintball Stores     |     Hot Deals     |     Paintball Forums     |     Chat
Go Back   Paintball Forums > Specific Marker Forums > Dragun / Odyssey


Reply
 
Thread Tools Display Modes
Old 05-02-2004, 03:02 PM   #21
BlackdLCD
Rip Ya Up
 
BlackdLCD's Avatar
 
Join Date: Nov 2002
Location: Show-Me MO
Send a message via AIM to BlackdLCD
i got an older dragun, and ive been having pinching problems. Instead of chopping the ball, the ball gets stuck inbetween part of the chamber and my bolt. It seems like the ball hasnt had a change to get far enough into the chamber, but i have an eggy. After this i either have to disassemble my gun, or recock to be able to fire again. Anybody know a solution to this?
__________________
M3 Black Dragun LCD 2k2
(ThE oRiGiNaL)
Light BLue
Zenitram stick trigger
Lapso SS Bigshot
PMI Pure Energy 68cu 3000psi
Clear Evlution II
Chrome CP Lightning Drop
Chrome Bob Long Torpedo Reg
Chrome CP On/Off ASA


Quote:
Originally posted by ZeroSkillet
vegitable oil all the way!!!!!
BlackdLCD is offline   Reply With Quote
Old 05-02-2004, 04:05 PM   #22
schoolsukz08
Registered User
 
Join Date: Mar 2003
Quote:
Originally posted by BlackdLCD
i got an older dragun, and ive been having pinching problems. Instead of chopping the ball, the ball gets stuck inbetween part of the chamber and my bolt. It seems like the ball hasnt had a change to get far enough into the chamber, but i have an eggy. After this i either have to disassemble my gun, or recock to be able to fire again. Anybody know a solution to this?
Is it pinching every time or every once in a while.
schoolsukz08 is offline   Reply With Quote
Old 05-02-2004, 04:53 PM   #23
BlackdLCD
Rip Ya Up
 
BlackdLCD's Avatar
 
Join Date: Nov 2002
Location: Show-Me MO
Send a message via AIM to BlackdLCD
its whenever i walk the trigger. if i fire slowly its fine, but when i walk it, it pinches after 3 or 4 shots.
__________________
M3 Black Dragun LCD 2k2
(ThE oRiGiNaL)
Light BLue
Zenitram stick trigger
Lapso SS Bigshot
PMI Pure Energy 68cu 3000psi
Clear Evlution II
Chrome CP Lightning Drop
Chrome Bob Long Torpedo Reg
Chrome CP On/Off ASA


Quote:
Originally posted by ZeroSkillet
vegitable oil all the way!!!!!
BlackdLCD is offline   Reply With Quote
Old 06-01-2004, 03:07 PM   #24
wakeupandbord
Registered User
 
wakeupandbord's Avatar
 
Join Date: Nov 2003
Location: Commerce, Michigan
Send a message via AIM to wakeupandbord
I need help with my TES!!!!!!!PLEASE REPLY

I have been trying to get my gun working correctly for a long long time and still no luck...Here's the story...

I live in Commerce, Michigan and I bought my gun about 3 or 4 months ago at Extreme Sports in Summit Mall. I am
NO noob and I have tried everything

(including over $500 in upgrades, making sure the gun is completely clean, oiling the gun, screwing with the regulator, taking it to the store for the supossid "EXPERTS" to fix, asking people how to fix it, trying new batteries all the time, and experimenting with my Egg II and my Ricochet Apache hoppers, cleaning the eye, taking the gun apart over and over, getting a new ball detent, experimenting with my Supa-Fly bolt and the stock bolt, trying different paintballs...etc) and my gun still has been nothing but problems (It chops like there is no tomorrow, it barely ever re-cocks, sometimes when I am walking the trigger the gripframe won't respond to some of the shots and most of the time I'm shooting slow so I can't be out-shooting the gun, and the gun can't even be mentioned in the same sentence with the word consistency. But with all of this in mind the two main problems I have are the re-cocking problems and the gun chopping)

It makes me mad to know that I was so unlucky to get such a defective gun, yet I searched for about 5 months on the Internet almost everyday to read the reviews of different guns and find the best one for around $300 and I chose this one and I still got screwed. My gun is in Alabama right now getting fixed (hopefully) by Dragun Empire/OGI.
I have taken my gun to the store where I brought it in countless times for testing and fixing and they always say "I didn't see any of the problems you were talking about" and I go home all excited that it works and I go buy a case of paintballs and i shoot it and it has all of the same problems.

Listed here are all of my upgrades and gun,
Blue to Black Fade TES $249
16 inch DYE Ultralight $89.99
PE 68ci 4500psi Fiber Wrapped Nitro tank $205.99
DYE Rhino Tank Cover $30
Egg II, and a Ricochet Apache $69 & $99
04 Shocktech Supa-Fly Bolt $50
04 Shocktech LPC $14
Air America Messiah LPR $89
Check It Products Clamping Feed Neck $25
Macro Line Kit $14
Physco B Drop Forward w/guage $35
New Factory Ball Detent $Free
= $969.98 If I added correctly, lol

I know that my gun is at OGI for repairs right now, but I would appreciate the help for future reference, to help others with the same problems, and I have a 5 man team and 3 of the people on my team have TES's and have the same problems and I do.
Can someone please help me with my gun and maybe give me some suggestions??? THANKS

Last edited by wakeupandbord : 06-01-2004 at 03:10 PM.
wakeupandbord is offline   Reply With Quote
Old 06-01-2004, 03:18 PM   #25
schoolsukz08
Registered User
 
Join Date: Mar 2003
I can help you, just get to the point with your questions cause I can't read though all the extra bull****. So just number your questions and I can try to answer.
schoolsukz08 is offline   Reply With Quote
Old 06-01-2004, 03:43 PM   #26
wakeupandbord
Registered User
 
wakeupandbord's Avatar
 
Join Date: Nov 2003
Location: Commerce, Michigan
Send a message via AIM to wakeupandbord
Quote:
Originally posted by Etang858
i just took apart the gun and looked at the internals. according to the diagram i should have a cup seal spring then a cup seal star and a cup seal. i'm missing the cup seal star and i never took the gun apart before. also it seems that the cup seal pin should thread into the cup seal, is this correct? the pin does not thread into the cup seal if this is whats supposed to happen. could this be the cause of all my recocking problems?

thanks
I had the same problem when I took my TES apart, I was mssing the cup seal star, but I think that they aren't supposed to come with them even though it's in the manual. They probably use the same manual for most of their guns and the other guns probably include the cup seal star unlike the TES.
wakeupandbord is offline   Reply With Quote
Old 09-01-2004, 02:47 PM   #27
wakeupandbord
Registered User
 
wakeupandbord's Avatar
 
Join Date: Nov 2003
Location: Commerce, Michigan
Send a message via AIM to wakeupandbord
Quote:
Originally posted by Etang858
i just took apart the gun and looked at the internals. according to the diagram i should have a cup seal spring then a cup seal star and a cup seal. i'm missing the cup seal star and i never took the gun apart before. also it seems that the cup seal pin should thread into the cup seal, is this correct? the pin does not thread into the cup seal if this is whats supposed to happen. could this be the cause of all my recocking problems?

thanks
for some reason the TES doesnt use a cup seal star.
__________________
SP ION Black
SP Quik lock feedneck Red
CP Ball Bearing Trigger Red
Planet Eclipse QEV
Orange Unicor Bolt
Evil Detonator Regulator
Halo B w/Empire shell and Victory Board
PE 68ci 4500psi
Dye Rhino Tank Cover-
Shocktech Body- $149.99
wakeupandbord is offline   Reply With Quote
Old 09-24-2004, 04:19 PM   #28
C-RaD
Banned
 
C-RaD's Avatar
 
Join Date: Aug 2004
Location: new jersey
Send a message via AIM to C-RaD
i had a problem with my tes not staying cocked... so i sent it in to dragun which was the only time i ever got alhold of them in my life. They said the problem was the soul pin and the plunger not being set right. Hope that helps
C-RaD is offline   Reply With Quote
Old 09-24-2004, 07:14 PM   #29
XxXanthraXxX
 
Join Date: Apr 2004
Location: Pembroke Pines Florida
good thing this problem can be fixed easlily. all u need to do is put some lube on ur sticker then, what i do, take off macroline, put 3 drops of lube in it, put it back into the fitting, then dryfire a few times. if u dont use macroline, put it into the lil hole in ur asa that ur air flows through. do it about 2 or 3 times after every day you play and ur gun wont mess up ne more its kinda a hastle but it keeps ur gun working
__________________
98% of Americans have tried pot if you are the 2% that hasn't put this in ur sig
XxXanthraXxX is offline   Reply With Quote
Reply



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 04:15 AM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Help / FAQ  |  Contact Us  |  About Us  |  Advertising Info  |  Link to Us  |  Privacy Policy  |  Terms of Use
Top

Paintball Review

Copyright © 2000-2007 Hillclimb Media